ASUS Routers  - Asus Routers - ASUS Routers Affected by Multiple Vulnerabilities

critical discovered in that allow an attacker can able to gain complete control of the router access and this flaw existed in all the AsusWRT .

There are 4 Vulnerabilities has been reported and all together will provide complete router access to attacker once router administrator login with his admin credentials then this flaw allows for retrieving the login/password using Administrator token.

According to seclists full disclosure, all the vulnerabilities are noticed to vendors and fixes has been realized.

Also Read Self-Destructive KillDisk Malware Overwrites then Deletes files and Force a Reboot

Highly Predictable Session Tokens (CVE-2017-15654)

This vulnerability allows an attacker can guess the administrator Login token in Router Which can be used to gain the admin user credentials when admin logged in the session.

stdlib rand function helps to generate a session token for an authenticated user and the Specific set of code initializes the random number generator each time a token is generated with router Login time.

Not Sufficient logged user IP validation(CVE-2017-15653)

Once attacker gain the session token using the Previous Vulnerability(CVE-2017-15653) attacker will perform the IP Verification mechanism and he will use special user-agent by sending the request.

Later Following Proof of Concept will be used for download current router configuration even if issued from a different than the logged user IP address

 curl "http://ROUTERADDRESS/s.CFG" -H "Cookie: asus_token=TOKEN" -H 'User-Agent: 
asusrouter-asusrouter-asusrouter-asusrouter'

Password Stored in Plain (CVE-2017-15656)

Asus routers stored all the passwords in the Plaintext in NVRAM memory which allow to downloading the backup and decode the password which leads to anyone can extract and see the admin password by Executing NVRAM (Show NVRAM).

Logged-in Information disclosure

Based on the all 3 major flaw Attack finally can able to retrieve the active session and exploit the router and gain the admin level access and the possible attacker can control the complete network that connected with compromised Router.

Along with above vulnerability Heap buffer overflow in multiple HTTP headers allows for an unauthenticated remote code execution for the routers not upgradable from 3.0.0.4.376.

This vulnerability also have been fixed and assigned  CVE(CVE-2017-15655)

All these Vulnerabilities are notified to the specific vendor and they release a fixed version 3.0.0.4.382.18495.

But vendor REFUSED to fix the vulnerability as the routers using the vulnerable firmware are already EOL for Head Buffer Overflow.



Source link

LEAVE A REPLY

Please enter your comment!
Please enter your name here