Harbor  - Harbor - Critical Vulnerability in Harbor let Hackers to Escalate Privilege

Harbor is a cloud-native registry that offers rich functions in container management that stores signs and scan images for vulnerabilities. It can be integrated with Docker Hub, Docker Registry, Container Registry, and other registries.

Security researchers from the cloud division of Unit 42, detected a critical vulnerability in Harbor that allows attackers to gain complete control over the registries by sending a malicious request.

According to researchers, more than 1,300 Harbor registries are open to the Internet with vulnerable default settings. The vulnerability can be tracked as CVE-2019-16097.

The critical privilege escalation vulnerability let anyone gain admin access to harbor registries with its default settings.

Harbor Vulnerability

According to researchers, attackers can launch various attack vectors by gaining admin access, they can delete images, poison the registry by replacing with a malicious one. Also, they can create a new admin user.

Once they get connected with registry via docker, attackers can replace the images to include malware, crypto miners or even worse.

Researcher scan reveals that more than 2,500 Harbors online, out of the 1,300 registries found vulnerable.

Security Patches

Harbor team patched the vulnerability with versions 1.7.6 and 1.8.3 that released on September 18. Developers added a check to prevent non-admin users in creating new admin users.

If you are having an out-of-date version, it is recommended to update immediately or disable Internet access. The vulnerability exists with 1.7.0 – 1.8.2 versions.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity updates





Source link

No tags for this post.

LEAVE A REPLY

Please enter your comment!
Please enter your name here