Privilege Escalation  - cisco 11234 - Privilege Escalation Flaw in ASA Allows Attackers To Read or Write Files

A vulnerability discovered in Cisco allows an lowest privilege user to overwrite the system’s firmware, full configuration file, and to create new users.

The vulnerability was identified by Tenable, tracked as CVE-2018-15465, allows a remote attacker to perform privileged actions in the web interface.

To exploit this vulnerability the attacker “requires the HTTP interface for IOS to be enabled, and the “aaa” authentication scheme needs to be set, which is not part of the ASAv default configuration.”

The vulnerability is due to the improper validation of user management in the webmanagement, an attacker could exploit this vulnerability by sending a crafted HTTP requests through HTTPS to the affected as an unprivileged user.

An attacker could exploit the vulnerability to retrive from the device or to upload and replace software images on the device.

The vulnerability affects all the Cisco ASA Software running with web management access enabled.

Now Cisco has released an advisory and patches, enabling command authorization prevents the exploitation of this vulnerability.

Cisco recommends “Administrators who use the Adaptive Security Device Manager (ASDM) to manage the ASA are advised to enable command authorization by using the ASDM because doing so will allow the ASDM to push predefined command sets for different privilege to the ASA.”

Related

Cisco Releases Security Updates that Covers 16 Vulnerabilities that had Critical and High Impact

Cisco Released Security Updates for Multiple Vulnerabilities that Affected Cisco Products

Cisco Released Critical Security Updates for Vulnerabilities that Affected Cisco Products



Source link

LEAVE A REPLY

Please enter your comment!
Please enter your name here