BIND DNS  - h3PzT1556289246 - BIND DNS Software Flaw Let Remote Attackers to Cause DOS attack

Internet Systems Consortium (ISC) published security updates for vulnerabilities in BIND DNS software that allows an remote attacker to cause a denial-of-service condition.

BIND stands for “Berkeley Internet Name Domain” is the most popular Domain Name System used to resolve DNS queries for users. It was written by graduate students at the University of California, Berkeley.

BIND DNS Vulnerability

CVE-2018-5743

Following are the version affected 9.9.0 -> 9.10.8-P1, 9.11.0 -> 9.11.6, 9.12.0 -> 9.12.4, 9.14.0, preview editions 9.9.3-S1 -> 9.11.5-S3, and 9.11.5-S5. The versions 9.13.0 -> 9.13.7 of the 9.13 development branch are also affected.

The vulnerability resides in the code which uws intended to limit the number of connections, an error with the code can be exploited to grow the connection beyong limit.

It can be tracked as CVE-2018-5743 and there is no exploits at this time, the vulnerability can be fixed by updating to following versions that includes BIND 9.11.6-P1, BIND 9.12.4-P1, BIND 9.14.1.

CVE--6467

9.12.0-> 9.12.4, 9.14.0 and 9.13 development branch are affected.A error in the nxdomain-redirect feature can cause an assertion failure in query.c if the alternate namespace used by nxdomain-redirect is a descendant of a zone that is served locally.

An attacker who can deliberately trigger the condition on a server with a vulnerable configuration can cause BIND to exit, denying service to other clients.

It can be tracked as CVE-2019-6467 and there is no exploits at this time, the vulberability can be fixed by updating to following versions that includes BBIND 9.12.4-P1 and BIND 9.14.1.

CVE-2019-6468

BIND Supported Preview Edition version 9.10.5-S1 -> 9.11.5-S5. ONLY BIND Supported Preview Edition releases are affected.

If nxdomain-redirect is enabled (via configuration) in a vulnerable BIND release, a malicious party can cause BIND to exit by deliberately triggering the bug.

It can be tracked as CVE-2019-6468 and there is no exploits at this time, the vulberability can be fixed by updating to following versions that includes BIND 9.11.5-S6 and BIND 9.11.6-S1.

Download Free E-book to learn about complete Enterprise Security Implementation & Mitigation Steps – Download Free-Ebook Here.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity updates also you can take the Best Cybersecurity courses online to keep your self-updated.





Source link

No tags for this post.

LEAVE A REPLY

Please enter your comment!
Please enter your name here