RCE Vulnerability in Millions of Exim Email Server Let Hackers Execute Arbitrary Command & Control the Server Remotely  - Exim 2Bserver - RCE Flaw in Exim Email Sever Let Hackers Execute Arbitrary Command

Critical Remote command execution vulnerability that affected Exim Email Server versions 4.87 to 4.91 let a local attacker or a remote attacker(with limited boundary) can execute an arbitrary command and exploit the server.

Exim is a mail transfer agent which is used on Unix-like operating systems for sending, receiving and routing the email messages. also, it is free software distributed under the terms of the General Public License (GNU)

Both local and remote attacker could exploit this vulnerability, but there are certain non-default configurations restriction take place for the remote attacker in order to execute the arbitrary commands.

RCE means Remote Command Execution, not Remote Code Execution: an attacker can execute arbitrary commands with execv(), as root and there is no memory corruption or ROP (Return-Oriented ) is involved in this flaw.

In order to exploit this vulnerability remotely in the default configuration, an attacker must keep a connection to the vulnerable server open for 7 days which can be possible by transmitting one byte every few minutes.

But the complexity of the Exim code, researcher not guaranteed that, it take longer time to exploit but there may be alternative fast method exist.

Exim Email Server are vulnerable by default since its older version 4.87 that was released on April 6, 2016), and the vulnerability was fixed in version 4.92 on Feb .

According to Qualys research, It was not identified as a security vulnerability, and most operating systems are therefore affected. For example, we exploit an up-to-date Debian distribution (9.9) in this advisory.

“We believe that it makes no sense to delay this any longer than that: this vulnerability is trivially exploitable in the local and non-default cases (attackers will have working exploits before that, public or not); and in the default case, a remote attack takes a long time to succeed” OpenWall reported.

This vulnerability referred as “The Return of the WIZard”, is a reference to Sendmail’s ancient WIZ and DEBUG vulnerabilities.

Exim’s maintainers said that there is no evidence that the hole is under active exploitation and that the patch “exists already.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity updates also you can take the Best Cybersecurity courses online to keep your self-updated.

Also Read: Penetration Testing Mail Server with Email Spoofing – Exploiting Open Relay configured Public Mail Servers





Source link

No tags for this post.

LEAVE A REPLY

Please enter your comment!
Please enter your name here